using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\w{4,}\b)(?:.*?\1){4,}";
string input = @"je veux juste tester si le mot marche bien ou non
Je teste Bonjour helloo Bonjour toto Bonjour Bonjour tata Bonjour titi Bonjour ok Bonjour test
le mot et Bonjour
Monument test Monument test Monument bla Monument hihi Monument haha Monument Monument
Bonjour hello Bonjour Bonjour";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}