import Foundation
let pattern = #"(\b\w{4,}\b)(?:.*?\1){4,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
je veux juste tester si le mot marche bien ou non
Je teste Bonjour helloo Bonjour toto Bonjour Bonjour tata Bonjour titi Bonjour ok Bonjour test
le mot et Bonjour
Monument test Monument test Monument bla Monument hihi Monument haha Monument Monument
Bonjour hello Bonjour Bonjour
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)