use strict;
my $str = 'je veux juste tester si le mot marche bien ou non
Je teste Bonjour helloo Bonjour toto Bonjour Bonjour tata Bonjour titi Bonjour ok Bonjour test
le mot et Bonjour
Monument test Monument test Monument bla Monument hihi Monument haha Monument Monument
Bonjour hello Bonjour Bonjour';
my $regex = qr/(\b\w{4,}\b)(?:.*?\1){4,}/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}