$re = '/(\b\w{4,}\b)(?:.*?\1){4,}/ms';
$str = 'je veux juste tester si le mot marche bien ou non
Je teste Bonjour helloo Bonjour toto Bonjour Bonjour tata Bonjour titi Bonjour ok Bonjour test
le mot et Bonjour
Monument test Monument test Monument bla Monument hihi Monument haha Monument Monument
Bonjour hello Bonjour Bonjour';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);