#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bthis.+?description"
Local $sString = "this is description" & @CRLF & _
"this is description2" & @CRLF & _
"this is" & @CRLF & _
"test this is a description test" & @CRLF & _
"" & @CRLF & _
"thisdescription" & @CRLF & _
"" & @CRLF & _
"this description description"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")