$re = '/\bthis.+?description/m';
$str = 'this is description
this is description2
this is
test this is a description test
thisdescription
this description description';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);