re = /\bthis.+?description/m
str = 'this is description
this is description2
this is
test this is a description test
thisdescription
this description description'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end