const regex = /\bthis.+?description/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bthis.+?description', 'gm')
const str = `this is description
this is description2
this is
test this is a description test
thisdescription
this description description`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}