using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=volume.*?href=\"").*?(?=\"")";
string input = @"<br>volume 1 <a href=""https://www.google.com"" /a><br>
<br>image <a href=""https://www.facebook.com"" /a><br>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}