$re = '/(?<=volume.*?href=\").*?(?=\")/i';
$str = '<br>volume 1 <a href="https://www.google.com" /a><br>
<br>image <a href="https://www.facebook.com" /a><br>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);