#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)@(\S+) (\S+) (\S+(?: -> \S+)*) ?((?:(?!\*\/).)*)"
Local $sString = "/**" & @CRLF & _
" * Class Object" & @CRLF & _
" * @package Model\Example\Objects" & @CRLF & _
" * @property-read int id" & @CRLF & _
" * @property order_id" & @CRLF & _
" * @property string|NULL external_order_id -> externalOrderId" & @CRLF & _
" * @property string order_source" & @CRLF & _
" * @property int order_source_id" & @CRLF & _
" * @property string order_source_info foo, foo, bar." & @CRLF & _
" * @property int order_status_id" & @CRLF & _
" * @property int date_add" & @CRLF & _
" * @property int date_confirmed" & @CRLF & _
" * @property int date_in_status" & @CRLF & _
" * @property string user_login" & @CRLF & _
" * @property string phone" & @CRLF & _
" * @property string email" & @CRLF & _
" * @property array products 21 foobar*/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")