import re
regex = re.compile(r"@(\S+) (\S+) (\S+(?: -> \S+)*) ?((?:(?!\*\/).)*)", flags=re.MULTILINE)
test_str = ("/**\n"
" * Class Object\n"
" * @package Model\\Example\\Objects\n"
" * @property-read int id\n"
" * @property order_id\n"
" * @property string|NULL external_order_id -> externalOrderId\n"
" * @property string order_source\n"
" * @property int order_source_id\n"
" * @property string order_source_info foo, foo, bar.\n"
" * @property int order_status_id\n"
" * @property int date_add\n"
" * @property int date_confirmed\n"
" * @property int date_in_status\n"
" * @property string user_login\n"
" * @property string phone\n"
" * @property string email\n"
" * @property array products 21 foobar*/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")