import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@(\\S+) (\\S+) (\\S+(?: -> \\S+)*) ?((?:(?!\\*\\/).)*)";
final String string = "/**\n"
+ " * Class Object\n"
+ " * @package Model\\Example\\Objects\n"
+ " * @property-read int id\n"
+ " * @property order_id\n"
+ " * @property string|NULL external_order_id -> externalOrderId\n"
+ " * @property string order_source\n"
+ " * @property int order_source_id\n"
+ " * @property string order_source_info foo, foo, bar.\n"
+ " * @property int order_status_id\n"
+ " * @property int date_add\n"
+ " * @property int date_confirmed\n"
+ " * @property int date_in_status\n"
+ " * @property string user_login\n"
+ " * @property string phone\n"
+ " * @property string email\n"
+ " * @property array products 21 foobar*/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}