using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\%\{(?<func>[a-zA-Z0-9_]+)((\.|\"")*(?<name>[a-zA-Z0-9_]+)\=\""(?<value>[^\""]+)\"")*\}\%";
string input = @"%{test.id=""123"".status=""true""}%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}