package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\%\{(?<func>[a-zA-Z0-9_]+)((\.|\")*(?<name>[a-zA-Z0-9_]+)\=\"(?<value>[^\"]+)\")*\}\%`)
var str = `%{test.id="123".status="true"}%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}