$re = '/\%\{(?<func>[a-zA-Z0-9_]+)((\.|\")*(?<name>[a-zA-Z0-9_]+)\=\"(?<value>[^\"]+)\")*\}\%/m';
$str = '%{test.id="123".status="true"}%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);