re = /\%\{(?<func>[a-zA-Z0-9_]+)((\.|\")*(?<name>[a-zA-Z0-9_]+)\=\"(?<value>[^\"]+)\")*\}\%/m
str = '%{test.id="123".status="true"}%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end