using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\""line\"":\""(?<time>.+)\|(?<log_level>.+)\|(?<Controller>.+)\|(?<Message>.+\}|.+?)\""";
string input = @"{""line"":""18:48:17.990|INFO|PController|Plex event is media.pause}"",""source"":""stdout"",""tag"":""4e263fa2001d""}
{""line"":""22:38:47.839|INFO|PController|{\""Id\"":\""SMf1bc2466b1\"",\""ErrorMessages\"":null}"",""source"":""stdout"",""tag"":""b5fcd8b8b5a4""}
{""line"":""22:38:47.839|INFO|PController|This is another test"",""source"":""stdout"",""tag"":""b5fcd8b8b5a4""}
{""line"":""18:56:37.212|INFO|PController|media.stop"",""source"":""stdout"",""tag"":""4e263fa2001d""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}