import re
regex = re.compile(r"\{\"line\":\"(?<time>.+)\|(?<log_level>.+)\|(?<Controller>.+)\|(?<Message>.+\}|.+?)\"", flags=re.MULTILINE)
test_str = ("{\"line\":\"18:48:17.990|INFO|PController|Plex event is media.pause}\",\"source\":\"stdout\",\"tag\":\"4e263fa2001d\"}\n\n"
"{\"line\":\"22:38:47.839|INFO|PController|{\\\"Id\\\":\\\"SMf1bc2466b1\\\",\\\"ErrorMessages\\\":null}\",\"source\":\"stdout\",\"tag\":\"b5fcd8b8b5a4\"}\n\n"
"{\"line\":\"22:38:47.839|INFO|PController|This is another test\",\"source\":\"stdout\",\"tag\":\"b5fcd8b8b5a4\"}\n\n"
"{\"line\":\"18:56:37.212|INFO|PController|media.stop\",\"source\":\"stdout\",\"tag\":\"4e263fa2001d\"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")