import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SALARY:(?P<salary_min>\\d+(?:k|K)?)(?:\\s*\\-\\s*(?P<salary_max>\\d+(?:k|K)?)?)?(?:\\s?(?P<currency>[A-Za-z]{3}))?";
final String string = "SALARY:120k-200kUSD\n"
+ "SALARY:120k EUR\n"
+ "SALARY:120000 PLN\n"
+ "SALARY:120k-200kusd\n"
+ "SALARY:120k-200k";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}