const regex = new RegExp('SALARY:(?P<salary_min>\\d+(?:k|K)?)(?:\\s*\\-\\s*(?P<salary_max>\\d+(?:k|K)?)?)?(?:\\s?(?P<currency>[A-Za-z]{3}))?', 'g')
const str = `SALARY:120k-200kUSD
SALARY:120k EUR
SALARY:120000 PLN
SALARY:120k-200kusd
SALARY:120k-200k`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}