$re = '/SALARY:(?P<salary_min>\d+(?:k|K)?)(?:\s*\-\s*(?P<salary_max>\d+(?:k|K)?)?)?(?:\s?(?P<currency>[A-Za-z]{3}))?/';
$str = 'SALARY:120k-200kUSD
SALARY:120k EUR
SALARY:120000 PLN
SALARY:120k-200kusd
SALARY:120k-200k';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);