import re
regex = re.compile(r"SALARY:(?P<salary_min>\d+(?:k|K)?)(?:\s*\-\s*(?P<salary_max>\d+(?:k|K)?)?)?(?:\s?(?P<currency>[A-Za-z]{3}))?")
test_str = ("SALARY:120k-200kUSD\n"
"SALARY:120k EUR\n"
"SALARY:120000 PLN\n"
"SALARY:120k-200kusd\n"
"SALARY:120k-200k")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")