#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([\d]{5})-([\d]{7})-([\d]{1}))|(([\d]{5})([\d]{7})([\d]{1}))|(([\d]{5}) ([\d]{7}) ([\d]{1}))$"
Local $sString = "// Allow these: " & @CRLF & _
"1234512345671" & @CRLF & _
"12345-1234567-1" & @CRLF & _
"" & @CRLF & _
"// Don't Allow" & @CRLF & _
"12345 1234567-1" & @CRLF & _
"12345-1234567 1" & @CRLF & _
"12345123456718" & @CRLF & _
"12345-1234567-71" & @CRLF & _
"12345-12345678-1" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")