re = /^(([\d]{5})-([\d]{7})-([\d]{1}))|(([\d]{5})([\d]{7})([\d]{1}))|(([\d]{5}) ([\d]{7}) ([\d]{1}))$/m
str = '// Allow these:
1234512345671
12345-1234567-1
// Don\'t Allow
12345 1234567-1
12345-1234567 1
12345123456718
12345-1234567-71
12345-12345678-1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end