package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([\d]{5})-([\d]{7})-([\d]{1}))|(([\d]{5})([\d]{7})([\d]{1}))|(([\d]{5}) ([\d]{7}) ([\d]{1}))$`)
var str = `// Allow these:
1234512345671
12345-1234567-1
// Don't Allow
12345 1234567-1
12345-1234567 1
12345123456718
12345-1234567-71
12345-12345678-1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}