#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\d+(?:(?:\s?[a-zA-Z]+)+(?:,|\s)+)+(?:[A-Za-z][A-Ha-hK-Yk-y]?[0-9][A-Za-z0-9]? ?[0-9][A-Za-z]{2}|[Gg][Ii][Rr] ?0[Aa]{2})"
Local $sString = "Hi Alice" & @CRLF & _
"" & @CRLF & _
"I hope you're well. This is my address:" & @CRLF & _
"" & @CRLF & _
"1 Test Street" & @CRLF & _
"Test Town," & @CRLF & _
"AA1 1AA" & @CRLF & _
"" & @CRLF & _
"Please get in touch soon. I have another address: 32 Island Road, Placington, AA2 2AA" & @CRLF & _
"" & @CRLF & _
"Kind regards" & @CRLF & _
"Dan"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")