use strict;
my $str = 'Hi Alice
I hope you\'re well. This is my address:
1 Test Street
Test Town,
AA1 1AA
Please get in touch soon. I have another address: 32 Island Road, Placington, AA2 2AA
Kind regards
Dan';
my $regex = qr/\d+(?:(?:\s?[a-zA-Z]+)+(?:,|\s)+)+(?:[A-Za-z][A-Ha-hK-Yk-y]?[0-9][A-Za-z0-9]? ?[0-9][A-Za-z]{2}|[Gg][Ii][Rr] ?0[Aa]{2})/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}