using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?:(?:\s?[a-zA-Z]+)+(?:,|\s)+)+(?:[A-Za-z][A-Ha-hK-Yk-y]?[0-9][A-Za-z0-9]? ?[0-9][A-Za-z]{2}|[Gg][Ii][Rr] ?0[Aa]{2})";
string input = @"Hi Alice
I hope you're well. This is my address:
1 Test Street
Test Town,
AA1 1AA
Please get in touch soon. I have another address: 32 Island Road, Placington, AA2 2AA
Kind regards
Dan";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}