package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.+\/p-\d+$`)
var str = `arthi/p-884294
http://www.camicado.com.br/jogo-panelas-ana-maria-braga-revestimento-ceramico-5-pecas-vermelho/p-775584`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}