re = /^.+\/p-\d+$/m
str = 'arthi/p-884294
http://www.camicado.com.br/jogo-panelas-ana-maria-braga-revestimento-ceramico-5-pecas-vermelho/p-775584'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end