$re = '/^.+\/p-\d+$/m';
$str = 'arthi/p-884294
http://www.camicado.com.br/jogo-panelas-ana-maria-braga-revestimento-ceramico-5-pecas-vermelho/p-775584';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);