import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "From: (?<from>[\\w\\W]+?)\\s+Client: (?<client>[\\w\\W]+?)\\s+Title: (?<Title>[\\w\\W]+?)\\s+Request: (?<request>[\\w\\W]+?)\\sLead: (?<lead>[\\w\\W]+?)\\sAttachment:";
final String string = "From: Client\n"
+ "Client: Question\n"
+ "Title: Additional INfo\n"
+ "Request: Request Here\n"
+ "Lead: Lead name here\n"
+ "Attachment:";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}