import re
regex = re.compile(r"From: (?<from>[\w\W]+?)\s+Client: (?<client>[\w\W]+?)\s+Title: (?<Title>[\w\W]+?)\s+Request: (?<request>[\w\W]+?)\sLead: (?<lead>[\w\W]+?)\sAttachment:")
test_str = ("From: Client\n"
"Client: Question\n"
"Title: Additional INfo\n"
"Request: Request Here\n"
"Lead: Lead name here\n"
"Attachment:")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")