re = /From: (?<from>[\w\W]+?)\s+Client: (?<client>[\w\W]+?)\s+Title: (?<Title>[\w\W]+?)\s+Request: (?<request>[\w\W]+?)\sLead: (?<lead>[\w\W]+?)\sAttachment:/
str = 'From: Client
Client: Question
Title: Additional INfo
Request: Request Here
Lead: Lead name here
Attachment:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end