const regex = /From: (?<from>[\w\W]+?)\s+Client: (?<client>[\w\W]+?)\s+Title: (?<Title>[\w\W]+?)\s+Request: (?<request>[\w\W]+?)\sLead: (?<lead>[\w\W]+?)\sAttachment:/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('From: (?<from>[\\w\\W]+?)\\s+Client: (?<client>[\\w\\W]+?)\\s+Title: (?<Title>[\\w\\W]+?)\\s+Request: (?<request>[\\w\\W]+?)\\sLead: (?<lead>[\\w\\W]+?)\\sAttachment:', 'g')
const str = `From: Client
Client: Question
Title: Additional INfo
Request: Request Here
Lead: Lead name here
Attachment:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}