package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?m)^(.*-[^-]{5})[^-]*$`)
    var str = `X008-TGa19-ER751QF7
X002-KF13-ER782cPU80
`
    var substitution = "\1"
    
    fmt.Println(re.ReplaceAllString(str, substitution))
}