const regex = new RegExp('^(.*-[^-]{5})[^-]*$', 'gm')
const str = `X008-TGa19-ER751QF7
X002-KF13-ER782cPU80
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);