$re = '/^(.*-[^-]{5})[^-]*$/m';
$str = 'X008-TGa19-ER751QF7
X002-KF13-ER782cPU80
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;