use strict;
my $str = 'X008-TGa19-ER751QF7
X002-KF13-ER782cPU80
';
my $regex = qr/^(.*-[^-]{5})[^-]*$/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";