using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{7}";
string input = @"16.1 14.3 8.8 7.0 7.85 13.29 18.75 13.08 13.10
6.7 5.4 6.39";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}