import Foundation
let pattern = #".{7}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
16.1 14.3 8.8 7.0 7.85 13.29 18.75 13.08 13.10
6.7 5.4 6.39
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)