import re
regex = re.compile(r".{7}")
test_str = ("16.1 14.3 8.8 7.0 7.85 13.29 18.75 13.08 13.10\n"
"6.7 5.4 6.39")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")