package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.{7}`)
var str = `16.1 14.3 8.8 7.0 7.85 13.29 18.75 13.08 13.10
6.7 5.4 6.39`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}