#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Contract Duration=).+|(?<=Minimum Acceptable Technical Scoring=).+|(?<=Is there previous contract=).+|(?<=Contract Number=).+|(?<=Project Name in Arabic=).+|(?<=Proposed End Date\s.+)\d{2}.\d{2}.\d{4}|(?<=Proposed Start Date\s.+)\d{2}.\d{2}.\d{4}|(?<=Payment terms=).+|(?<=Feasibility Study if Above 1M AED=).+"
Local $sString = "Contract Duration=2 years" & @CRLF & _
"Minimum Acceptable Technical Scoring=70%" & @CRLF & _
"Is there previous contract=NO" & @CRLF & _
"Contract Number=" & @CRLF & _
"Project Name in Arabic=??? ??? ??? ??? ???" & @CRLF & _
"Proposed Start Date (DD-MON-YYYY)=01/01/2023" & @CRLF & _
"Proposed End Date (DD-MON-YYYY)=31/12/2024" & @CRLF & _
"Payment terms=Others" & @CRLF & _
"Feasibility Study if Above 1M AED=NO"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")