using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Contract Duration=).+|(?<=Minimum Acceptable Technical Scoring=).+|(?<=Is there previous contract=).+|(?<=Contract Number=).+|(?<=Project Name in Arabic=).+|(?<=Proposed End Date\s.+)\d{2}.\d{2}.\d{4}|(?<=Proposed Start Date\s.+)\d{2}.\d{2}.\d{4}|(?<=Payment terms=).+|(?<=Feasibility Study if Above 1M AED=).+";
string input = @"Contract Duration=2 years
Minimum Acceptable Technical Scoring=70%
Is there previous contract=NO
Contract Number=
Project Name in Arabic=??? ??? ??? ??? ???
Proposed Start Date (DD-MON-YYYY)=01/01/2023
Proposed End Date (DD-MON-YYYY)=31/12/2024
Payment terms=Others
Feasibility Study if Above 1M AED=NO";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}