const regex = new RegExp('(?<=Contract Duration=).+|(?<=Minimum Acceptable Technical Scoring=).+|(?<=Is there previous contract=).+|(?<=Contract Number=).+|(?<=Project Name in Arabic=).+|(?<=Proposed End Date\\s.+)\\d{2}.\\d{2}.\\d{4}|(?<=Proposed Start Date\\s.+)\\d{2}.\\d{2}.\\d{4}|(?<=Payment terms=).+|(?<=Feasibility Study if Above 1M AED=).+', 'gm')
const str = `Contract Duration=2 years
Minimum Acceptable Technical Scoring=70%
Is there previous contract=NO
Contract Number=
Project Name in Arabic=??? ??? ??? ??? ???
Proposed Start Date (DD-MON-YYYY)=01/01/2023
Proposed End Date (DD-MON-YYYY)=31/12/2024
Payment terms=Others
Feasibility Study if Above 1M AED=NO`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}