use strict;
my $str = 'Contract Duration=2 years
Minimum Acceptable Technical Scoring=70%
Is there previous contract=NO
Contract Number=
Project Name in Arabic=??? ??? ??? ??? ???
Proposed Start Date (DD-MON-YYYY)=01/01/2023
Proposed End Date (DD-MON-YYYY)=31/12/2024
Payment terms=Others
Feasibility Study if Above 1M AED=NO';
my $regex = qr/(?<=Contract Duration=).+|(?<=Minimum Acceptable Technical Scoring=).+|(?<=Is there previous contract=).+|(?<=Contract Number=).+|(?<=Project Name in Arabic=).+|(?<=Proposed End Date\s.+)\d{2}.\d{2}.\d{4}|(?<=Proposed Start Date\s.+)\d{2}.\d{2}.\d{4}|(?<=Payment terms=).+|(?<=Feasibility Study if Above 1M AED=).+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}