import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{(.*?)\\}\\}";
final String string = "Всем привет!\n"
+ "Подскажите пожалуйста, как можно реализовать проверку всех файлов на наличие {{}} и если есть такой синтаксис, то вставить в это место текст из например {{blog/flowers.txt}}?\n"
+ "Т.е. если в файле есть {{}}, то он подставит в это место текст из указанного в нём файла.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}