use strict;
my $str = 'Всем привет!
Подскажите пожалуйста, как можно реализовать проверку всех файлов на наличие {{}} и если есть такой синтаксис, то вставить в это место текст из например {{blog/flowers.txt}}?
Т.е. если в файле есть {{}}, то он подставит в это место текст из указанного в нём файла.';
my $regex = qr/{{(.*?)}}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}